Introduction to The Geometer’s Sketchpad® Dynamic Geometry Software
© 2010-02-04 R. Meisel
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Use The Geometer’s Sketchpad® to Construct a Working Model of the
Pythagorean Theorem

(c) 2010-01-30 R. Meisel

In this activity, you will learn how to use the basic tools and menus of The Geometer’s Sketchpad® to
construct a dynamic working model the Pythagorean Theorem.

What is The Geometer’s Sketchpad®?

The Geometer’s Sketchpad® (GSP) is dynamic geometry software useful for exploring plane geometry,
algebra, calculus, statistics, and other branches of mathematics. It is possible to simulate three-
dimensional geometry as well. Thousands of sketches are available on the Internet, most of them free.
Version 4 is most commonly found in schools, although Version 5 was released late in 2009. Sketches are

upwardly compatible. Version 5 also includes a provision for saving files in a format that will work on
Version 4.

The Workspace
When you run GSP, the workspace looks like this:
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The tools buttons are at the side, and dropdown menus are along the top.

Draw a Right Triangle:
e Select the Straightedge Tool.
e Click and drag to draw a line segment bounded by two points.

Tip: You can draw a horizontal, vertical, or diagonal segment by holding down the Shift key.
Next, fix an angle at 90°.

e Select the right endpoint of the segment.

e Select the segment.

e From the Construct menu, select Perpendicular Line.
A line perpendicular to the segment is drawn through the point.

e Select the Point Tool.

e Draw a point on the perpendicular line.

e Select the perpendicular line.

e From the Display menu, select Hide Perpendicular Line.

Tip: Alternatively, hold down the CTRL key, and press h.

e Use the Straightedge Tool to draw segments that complete
the triangle.

Click and drag each of the vertices in turn. Notice that the triangle
remains a right triangle at all times.

Measure Lengths

e Select the three sides of the triangle.
e From the Measure menu, select Length.

Labels will appear for each of the vertices. Three length mAB=521cm
measurements will be displayed. m CA=575cm

mBC =2.42 cm
Save the Sketch

e From the File menu, select Save As... .

Navigate to a suitable directory, and select a descriptive name
for your sketch. B

e Select Save.
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Calculate Squares
e From the Measure menu, select Calculate... .

The calculator box will appear.

o Click on the measure of the length of the hypotenuse.

e Click on *, then 2 to complete the square.
e Click on OK.

The square of the hypotenuse will appear.

e From the Measure menu, select Calculate... .
e Click on the measure of one of the sides.

e Click on *, then 2 to complete the square.

e Click on +.

e Click on the measure of the other side.

e Click on *, then 2 to complete the square.

e Click on OK.

The sum of the squares of the other two sides will appear.

mAB=521cm (mCA)2=33.02cm?2
mCA=575cm (mAB)R+{mBC)2=32.02 cm?2
mBC = 2.42 cm

Tip: You can use the Selection Arrow Tool to move a measurement to a convenient location in the

workspace.

Click and drag each of the vertices in turn. Note
that the Pythagorean relationship holds at all
times.

Draw Squares on the Sides

To complete the model, you will draw squares on
the sides of the triangle. These will change
dynamically as you drag the vertices.

e Double-click on the vertex containing the
right angle. This marks the point as the centre of
rotation.

® Sclect one of the sides, and the vertex at the
end of the side.

e From the Transform menu, select Rotate... .

A faint point will be plotted to show you the
location of the rotated point and side. Note that
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rotations are counter-clockwise.

e Change the angle to 270°.
e Click on Rotate.

The rotated segment and point will appear.

e Double-click on point C to mark it as the centre of rotation.
e Rotate B and the segment BC about C.

e Use the Straightedge Tool to complete the square.

e Select the four vertices of the square.

e From the Construct menu, select Quadrilateral Interior.

The square will be filled in with colour. You
can select the interior, and change the colour by

selecting Color from the Display menu.

Tip: Alternatively, you can right-click on the A
interior, and select Color.

Use this procedure to draw squares on the other
sides of the triangle. Select colours of your choice.

Finally, construct a triangle interior for the right triangle,
and colour it.

Save your sketch.

Add a Page

You can add pages to your sketch.

e From the File menu, select Document Options... .
e Press Add Page.

e Select Blank Page.

e Press OK.

Your new page will appear. You could also have chosen
to duplicate the first page.

You can toggle among the pages using the buttons at the lower left of the workspace. You can also use
Document Options to change the names of the pages.
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Another Way to Draw a Right Triangle

e Select the Compass Tool.
e Draw a circle in the workspace.

Note that the circle is defined by a centre, and a point on the circle.

e Use the Transform menu to rotate the point on the circle 180° about the centre.

e Use the Straightedge Tool to draw a diameter.

e Use the Point Tool to draw another point on the circle.

e Use the Straightedge Tool to complete a triangle in the semicircle.

e Sclect the vertices of the triangle such that the point in the semicircle is the second one selected.
e From the Measure menu, select Angle.

The measure of the angle in the semicircle will appear. Drag each of the m<B'CB = 90.00°
vertices of the triangle in turn, and observe what happens.

e Hide the circle and its centre.

You can now complete a model of the Pythagorean Theorem using this
triangle, if desired.
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Use The Geometer’s Sketchpad® to Create and Save Custom Tools
(c) 2010-01-30 R. Meisel

In this activity, you will learn how to use The Geometer’s Sketchpad® to create custom tools, and save
them such that they are available for all documents.

What is a Custom Tool?
The Geometer’s Sketchpad® (GSP) comes with some basic tools, such as the Straightedge Tool for

drawing lines, rays, and line segments, and the Compass Tool for drawing circles based on a centre and a
point on the circumference. However, you can create tools to automate the drawing of virtually anything

that can be drawn with GSP. _
Mame
Standard Custom Tools |®| About This Folder.gsp
|®| Advanced Tools.gsp
GSP comes with a number of standard custom tools. However, before you 8] Animation Tools.gsp
can use them, you must copy them into your Tool Folder. The standard |®| Appearance Tools.gsp
custom tools are placed in the Sketchpad/Samples/Custom Tools directory & Conics.gsp
when you install GSP on your computer. You must copy the files in this ®| Fractions.gsp
folder to the Sketchpad/Tool Folder folder. ®| Pelygons.gsp

|®| Sample Tools.gsp
|®| Sliders.gsp
|®| Triangle Centers.gsp

Close GSP, and restart. Press and hold the Custom Tool button. A list of IW o -
custom tools appears. -

Tool Options...
. . . . Show Script View
You can experiment with the many different and useful tools available.
Creating a Custom Tool Advanced Tools

Anirnation Tools
You can create your own custom tool by making a sketch, selecting the Appearance Tools

elements that you want to be part of the tool, and then, selecting Create
New Tool... from the Custom Tool menu.

Conics
Fractions

Polygons
If you save the sketch in your Tool Folder, it will appear the next time to ¥

start GSP.

Sample Tools
Sliders

Triangle Centers
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Draw a Parallelogram
e Draw two line segments from the same starting point.
e Select one segment, and the endpoint of the other.
e From the Construct menu, select Parallel Line. N

e Repeat to draw another line to complete the figure ‘ .

e Select the two lines.
e From the Construct menu, select Intersection.
e Hide the two lines.

e Draw line segments to complete the parallelogram. * o

Create a Parallelogram Tool
e Click and drag to form a selection box.

This will select all objects within the box.

® Press the Custom Tool button.
o Sclect Create New Tool... .

The New Tool box will appear.

Tool Name:
e Name the tool Parallelogram. meame

® Press OK. |P'ara||eh:ugram

[ Show Script Yiew

Cancel | ] |

Press the Custom Tool button. Notice that the Parallelogram tool
appears in the list under This Document. If you save this document, and
give it to someone else, the tool will go with it. However, as soon as you
close the document, the tool will disappear from the list.

To save the tool permanently on your computer, you must save the document in the Tool Folder. It will
then appear the next time you start GSP. Before doing this, we’ll create another tool. You can create
many tools in one sketch, and then, save them all at once.

Let’s draw a few parallelograms before we proceed.
® Press the Custom Tool button.
e Select Parallelogram.
e Move the pointer to the workspace, and click once.
e Move the pointer, and click again.
e Move the pointer, and click a third time.

Notice that you need to define three points in order to draw a parallelogram.

The parts of the sketch that were hidden, i.e., the two intersecting lines, are not drawn when using the
tool. Even if you select Show All Hidden from the Display menu, you will not see them.
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e Select and delete all of the parallelograms except the first one.
e Select the Text Tool.
e Type some text such as “This tool draws a parallelogram.”

Add a Page

e From the File menu, select Document Options... .
e Press Add Page.

e Select Blank Page.

o Press OK.

Your new page will appear.
e From the File menu, select Document Options... .
Change the name of the page to Rhombus.
Change the name of the first page to Parallelogram. Then, return to the Rhombus page.
Draw a Rhombus
e Use the Compass Tool to draw a circle.
e Use the Point Tool to place another point point on the circle.
e Use the Straightedge Tool to draw line segments.
e Construct two lines to form the rhombus.

e Construct the intersection of the lines.

Your sketch will appear as shown.

e Hide the lines and the circle.
e Draw line segments to complete the rhombus.

Create a Rhombus Tool
e Click and drag to form a selection box.
e Press the Custom Tool button.
o Select Create New Tool... .

The New Tool box will appear.

o Name the tool Rhombus.
e Press OK.

Press the Custom Tool button. Notice that both the Parallelogram tool and the Rhombus tool appear in
the list under This Document.

The Geometer’s Sketchpad® Tutorial Page 9



® Press the Custom Tool button.

e Sclect Rhombus.

e Move the pointer to the workspace, and click once.
e Move the pointer, and click again.

Notice that you only need to define two points in order to draw a rhombus.
Save Your Tools for Other Sketches

e From the File menu, select Save As... .

e Navigate to the directory Sketchpad/Tool Folder.

e Type a name for the file, such as My Custom Tools.
® Press Save.

If you press the Custom Tool button, W Create New Tool...
you’ll notice that the new tools do not Tool Options...
appear. You must clos_e and restart GSP. Show Script View
Then, the new tools will appear.
-- Tool Folder --
Advanced Tools ]
Animation Tools r
Appearance Tools 2
Conics 2
Fracticns ]
My Custom Tools k Rhombus
Polygons 2 Parallelogram
Sample Tools 3
Sliders ]
Triangle Centers r
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Use The Geometer’s Sketchpad® to lllustrate a Geometrical Proposition
(c) 2010-01-31 R. Meisel

In this activity, you will learn how to use The Geometer’s Sketchpad® to derive and illustrate a
geometrical conjecture.

Part 1: Start with any quadrilateral. Find the midpoints of the sides. Join the midpoints with line
segments. Form a conjecture about the figure made up of the segments, and show evidence that your
conjecture is correct.

Sketch the Figure
e Use the Straightedge Tool to sketch any quadrilateral.
e Sclect the sides, and construct midpoints.
e Select the midpoints and construct line segments.

The interior quadrilateral appears to be a parallelogram.
® Select the sides of the interior quadrilateral.
e From the Measure menu, select Slope.

The slopes of opposite sides are equal. The figure is a parallelogram.
Drag the vertices of the original quadrilateral. The interior figure remains a parallelogram.
Drag any vertex until it overlaps the vertex next to it. Try both directions.

Part 2: Start with any quadrilateral. Find the midpoints of the sides. Erect an external perpendicular at the
midpoint, whose length is half the length of the corresponding side. Join the ends of opposite
perpendiculars to construct two line segments. Form a conjecture about the two segments, and show
evidence that your conjecture is correct.

e Use the Straightedge Tool to sketch any quadrilateral.

e Select the sides, and construct midpoints.

e Double-click a midpoint to select it as a centre of rotation.

e Click the point at one end of the same side.

e From the Transform menu, select Rotate... .

e [f necessary, change the angle to rotate outside the
quadrilateral.

e Press Rotate.

e Repeat for the other three sides.

e Draw line segments for the four perpendiculars.

e Join the ends of opposite perpendiculars.

The two segments appear to be orthogonal.
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e Construct the intersection of the two segments.
e Measure the angle at the intersection.

The two segments are orthogonal. Drag the vertices of the original quadrilateral. The two segments
remain orthogonal.

e Select the line.
e From the Measure menu, select Slope.

Part 3:

e Use the Straightedge Tool to sketch any acute triangle.

e Construct the midpoints of the sides.

e Construct altitudes.

e Construct the orthocentre: where the altitudes meet.

e Construct a point at the foot of each altitude.

e Hide the altitudes.

e Construct a line segment from each vertex to the
orthocentre.

e Construct the midpoints of the line segments.

e Hide the orthocentre and the line segments.

You should have nine points visible, other than the vertices of
the triangle. These points appear to lie on a circle.

e Make constructions necessary to find the centre of such a circle.
e Hide all constructions except the centre.
e Draw the circle.
Note that it passes through all nine points. This is called the Nine Point Circle.

Drag a vertex of the triangle. Note that the nine points remain on a circle.

Try another sketch, but use an oblique triangle.
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Use The Geometer’s Sketchpad® to Dynamically Display Derivatives

(c) 2010-01-31 R. Meisel

In this activity, you will learn how to dynamically work with derivatives in The Geometer’s Sketchpad®.

Graph a Function and Draw a Secant
e From the Edit menu, select Preferences... .
e Select the Text tab.
e Check the box For All New Points.
® Press OK.
e From the Graph menu, select Plot New Function...

® Type x " 2.
e Press OK.

The function and graph will be displayed.

e Use the Point Tool to draw two points on the function.

e Construct a line through the two points.
e Select the line.
e From the Measure menu, select Slope.

Drag each point independently, and observe how the slope of the secant changes.

Calculate the Derivative
e Select the function.
e From the Graph menu, select Derivative.
The derivative of the function will be displayed.
e Measure the coordinates of the first point A.
e Calculate the derivate using the x-coordinate of A.

® Drag point B towards point A.

Observe the relation between the slope of the secant and
the derivative as point B approaches A.

e From the Graph menu, select Plot New Function...

e Enter the expression f*(xa)*(X - Xa) + Ya
® Press OK.

The tangent at point A will be displayed.
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Drag point B towards point A. Observe the secant in relation to the tangent.
Construct Hide/Show Buttons

e Select point B, the secant, and the slope of the secant.

e From the Edit menu, select Action Buttons.

o Select Hide/Show.
A button will be displayed.

e Right-click on the button, and change the label to Hide Secant.
e Use the button to hide or show the secant.

In a similar manner, create another button to hide/show the tangent and its measurements.
Hide the secant. Drag point A along the curve, and observe what happens.

Show the secant.

Try Another Function
e Right-click on the function definition.

e Select Edit Function... . Hide Secant
e Change the function to x°. Hide Tangent
Observe what changes have occurred. Experiment with gy =
—
the secant and the tangent. Slope AB = 2.08
. . oo = 3-}(2 |
Try other functions of interest. ' ' '
X, =042
v, = 0.08 ’_J_,«-*"'
g f
1’:5“}:: 0.53 | Sl

..f"?j[‘x} = f'(}{A}-(X—KA]ﬂ'A
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Use The Geometer’s Sketchpad® to Create a Sierpinski Triangle: Iteration
(c) 2010-01-31 R. Meisel

In this activity, you will learn how to use iteration in The Geometer’s Sketchpad® to create a Sierpinski
Triangle.

What is a Sierpinski Triangle?

The Sierpinski Triangle is a fractal pattern first described in
1915 by the Polish mathematician Waclaw Sierpinski. The
pattern continues indefinitely, and looks the same under any level
of magnification. A Sierpinski Triangle with five levels is shown.

Set Up the Triangle
e From the Edit menu, select Preferences... .
e Select the Text tab.
® Check the box For All New Points.
o Press OK.

This will label all points as you create them.

e Use the Straightedge Tool to draw a triangle.

e Select the sides AB, BC, and CA, in order.

e From the Construct menu, select Midpoints.

e Use the Straightedge Tool to join the midpoints.

e Select the three midpoints.

e From the Construct menu, select Triangle Interior.

e If desired, you can right-click on the triangle, and change the
Color.

Iterate the Pattern
Map the pattern in the large triangle into each of the three white triangles.
e Select, in order, the points A, B, and C.
e From the Transform menu, select lterate... .
e Click on F, B, and D, in order.
e Press the Structure button.
e Select Add New Map.
This maps the vertices of the triangle ABC to the vertices of the triangle FBD.

In a similar manner, map ABC onto EDC, and AFE.

e Click on E, D, and C, in order.
e Press the Structure button.
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e Select Add New Map.
e Click on A, F, and E, in order.
e Press Iterate.

The mapping will be iterated 3 times, the default setting.
Clean up the diagram by selecting and hiding all of the points.

Change the Iterations

e Use the Selection Arrow Tool to draw a selection box
around the entire triangle.

® Press + to increase the number of iterations, or — to
decrease the number of iterations.

Sierpinski Tile

Extend the method to form a tile.
e Draw a square ABCD.
e Construct midpoints for the sides.
e Join the midpoints with line segments.
e Construct midpoints for the segments.
e Join the second set of midpoints.

Your diagram should look much like this at this stage.

e Construct triangle interiors for the smaller triangles. K

Determine a mapping that results in the pattern shown. Then,
apply and iterate the mapping.

Select the tile, and experiment with the number of iterations.

Note: GSP will differentiate functions much like a Computer
Algebra System (CAS).
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Use The Geometer’s Sketchpad® for Computer Graphics Imagery (CGl)

(c) 2010-02-01 R. Meisel

In this activity, you will learn how to use The Geometer’s Sketchpad® as a CGIl program, investigating
how computers are used in the motion picture industry to create special effects needed in modern film-
making. This kind of software makes heavy use of trigonometry to render three-dimensional objects on a
two-dimensional computer screen.

Although The Geometer's Sketchpad® is a two-dimensional program, it can be used to represent and
animate three-dimensional representations in a limited way.

Create two shapes.

Part 1: Morph one shape into another. 3 ]
e Use the Straightedge Tool to draw a letter H. [ [

e Select all points and line segments, and copy.

e Paste a copy of H, and move it away from the original.
e Draw points on the copy to form the letter X.

e Select all points and line segments on the X.

e From the Edit menu, select Action Buttons.

e Create a Hide/Show button for the X.

Morph the H into the X.

e Show the X.

e Select the upper left point on the H.

e Select the upper left point on the X.

e Working clockwise, continue selecting points, alternating between H and X.
e From the Edit menu, select Action Buttons.

e Select Movement... .

e Click on the Label tab, and change the name to : H to X.

® Press OK.

e Hide X.

e Press the H to X button.

The H will morph smoothly into the X. To return the H to the starting position, press CTRL Z.

Create starting and finishing shapes.

Right-click on the H to X button. Experiment with the movement settings.

Part 2: Make an Object Fly and Turn

e Use the Straightedge Tool to draw an object cube.

e Create quadrilateral interiors to colour two of the faces as shown.
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e Draw a larger, rotated version of the cube to the right and down.
e Determine how points on the object cube match with the image cube.
e Select pairs of matching points, in order.

e From the Edit menu, select Action Buttons.

e Select Movement... .

e Click on the Label tab, and change the name to : Fly and Turn.
® Press OK.

e Sclect all elements of the image cube.

e From the Edit menu, select Action Buttons.

e Create a Hide/Show button for the image cube.

e Hide the image cube.

e Press the Fly and Turn button.

The object cube will appear to fly, turn, and move closer.Note that

the aspect of the cube does not remain quite right as it flies. To fix

this problem, points are usually constrained to fly along a predetermined path. You can’t have spaceships
or dinosaurs changing aspect as they move.

Part 3: Show Actions in Sequence
You can combine several motions to form a sequence of actions.

e Draw 8 points close together. o @
e Create a Hide/Show button for the points.
e Map the points on the object cube to the cluster of 8 points.
e Create a movement button. Label it Hyperspace.
e Hide the point cluster.
® Press the Fly and Turn Button, and then the Hyperspace button.

The object cube first flies to the image cube position, and then, off into hyperspace.
Press CTRL Z twice to return the object cube to its initial position.

You can create a button that combines the two motions.
e Select the Fly and Turn button, and the Hyperspace button, in order.
e From the Edit menu, select Action Buttons.
e Select Presentation... .
e Select the Sequentially button.
o Press OK.

A new button called Sequence 2 Actions will be displayed. Press this button. The actions will occur
sequentially.

Finally, you can made the object disappear after going into Hyperspace. Create a Hide/Show button for

the object cube. Select the Fly and Turn, Hyperspace, and Hide Object buttons. Create a presentation
button. When you press this button, the object cube will disappear after going into hyperspace.
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